Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2014, 12:56 PM
cbjr's Avatar
CBJR
 
Join Date: Jul 2014
Location: Beachwood OH
Posts: 18
Need help with crank position sensor 1990 190e 2.6

Hi i have a rough idle and sputtering issue with my 190e. I mentioned about the sputtering issue in another post in detail. ( 190e 2.6 Sputters when hard on acceleration. (1990) )
So one fellow from the forum reminded me the crank position sensor might be the problem. Since i have also a inconsistent idle and takes 2 trys to start the car i thought it might be the problem. My s500 did the no start because of cps few months ago. But my problem is i couldnt spot the cps at the back of the engine. I checked some cables going back side of the engine but because of intake i couldnt see it well. Isthere any way to reach it easilyor do i have to remove the intake? And if someone can point out where exactly is the cps i will be so happy. Thank you very much.

__________________
'93 190E 2.6 160.000 miles (sold)
'90 190E 2.6 201.000 miles
'02 S500 42.000 miles (sold)
'07 Subaru Forester 150.000 miles (Totalled)
'12 Toyota Yaris Sedan 100.000 miles (Daily)
Reply With Quote
  #2  
Old 08-24-2014, 02:23 PM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,768
On my m104 it is above the starter.I ran over some limbs,and it unplugged it.
__________________
A nice nuclear war sounds nice,reduce man's population 90% evenly around the planet
Reply With Quote
  #3  
Old 08-25-2014, 04:14 AM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,979
Follow one off the wires that goes from the ezl to the back. It's located behind the oil filter housing.
You might have a stuck intake valve though. I did. Test the cps by unplugging it and starting the car

__________________

1990 190E 2.6L
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page