Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-10-2014, 08:19 PM
Registered User
 
Join Date: Feb 2013
Location: South carolina
Posts: 47
W126 '88 420SEL starting issues

I just purchased a '88 420SEL to keep my 300SD company. I knew she has issues going in but the body is good, the paint decent and the interior is ok. The oil looks good as does the trans fluid with no odd smell or color. The plugs aren't discolored and the fuel pumps energize. The PO had the ignition switch replaced so the key doesn't match the doors/trunk (and he couldn't find the key for those). Could I use the VIN at the dealer to get a new door/trunk key? The known issues pre-purchase was rough idle and having to start in neutral.

I had a feeling the neutral safety switch could either be faulty or needing adjustment. I've gone through the forum to get ideas and that I feel it's most likely the culprit. Do the shift linkage bushings really cause that much a misalignment for a no-start? Because she won't start now at all and has no reverse lights. Battery voltage checks fine but I need to go through the fuse box. I have a couple questions; 1) I ran across a reference to a starter junction block on the passenger (right) side. Is this mounted low, high or hidden on a '88, 2) There is a relay located just behind the right headlight that energizes when the key is turned to start. Would this be part of the starter circuit possibly security? The Star Tech I can access doesn't cover disc 2 where the '88 diagrams are. Also is there a copy of the fuse box sheet on this site?
EDIT: Looking a little more through the forum I found the link to access disc 2. This in turn gives me the fuse box diagram. So thankful for this site's information and help!!

The rough idle obviously will come next but searching the forum has given me ideas as to where to look in troubleshooting.

The exterior is Champagne OR Impala metallic (I think that is correct) with either a cream or mushroom interior. I still haven't learned how to decode the radiator tag properly. I purchased her at the very least for parts and to save her from the PO taking her to salvage. Thank you for any direction or ideas.

__________________
1983 300SD
1988 420SEL

Last edited by coolram62; 09-16-2014 at 04:08 PM. Reason: information
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page