Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2014, 12:13 PM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,774
studder when first give throttle,when warm

Yes my 98 m104 engine,studders when giving full throttle when engine is warm.I had a large hose fall off air pump,i reconnected,and it runs a little better.Trouble is too,when I remove oil cap,when engine is running no change in idle.I do have vaccum to fuel regulator,but I don't believe its enough,should it be 16 psi?I've felt every vacuum hse,sprayed carb cleaner around connections,intake manifold gasket,where plastic manifold joins aluminum part,no change in idle.
I thinking can that large round valve near intake manifold be sticking open.Called a air pump check valve?

__________________
I created you,I love you,don't love me? burn in hell forever. sounds like a human
Reply With Quote
  #2  
Old 12-07-2014, 02:42 AM
Registered User
 
Join Date: May 2007
Location: Arizona
Posts: 757
I know it's a totally different animal, but on my E420 (M119 engine), there are two vacuum lines that run across the front of the engine, right behind the air pump, over to the EGR circuitry behind the right front headlight. I was messing with my air pump a while back and noticed these lines were old and brittle. I know you checked for leaks by spraying, but these lines are far enough away from the engine that you might not notice.

On my car, at idle I see about 18" of vacuum. Are you getting any codes? Could be a bad MAF sensor too.
__________________
1993 400E, 256,000 miles (totaled)
1994 E420, 200,000+ miles
1995 E420, 201,000 miles
Reply With Quote
  #3  
Old 12-07-2014, 08:10 AM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,774
yes,I felt the full lenght of rubber pipes.I will try something today,as I read these two things might be at fault.The air pump,and air pump valve.I will block off these hoses,then test vacuum.If it works,I will just run with them blocked,as they don't have testing in my state.
My Maf is new but I will switch,can't read codes.But I will look for used NAPA scanner next year.
__________________
I created you,I love you,don't love me? burn in hell forever. sounds like a human
Reply With Quote
  #4  
Old 12-07-2014, 11:31 PM
Registered User
 
Join Date: May 2007
Location: Arizona
Posts: 757
During the process of troubleshooting an idle hiccup this year, I swapped out a spare MAF that turned out to be bad. It would cough on initial acceleration, but I didn't have it on the car long enough to do a full throttle test.

When I checked the codes using the J. Forgione "home brew" blink reader, I was getting a code that indicated the voltage at the hot wire MAF sensor was either too low or too high.

Also, those vacuum hoses leading to my EGR switching behind the right headlight are not rubber--they were about 3/16" diameter plastic and were totally fossilized.
__________________
1993 400E, 256,000 miles (totaled)
1994 E420, 200,000+ miles
1995 E420, 201,000 miles
Reply With Quote
  #5  
Old 12-08-2014, 07:08 AM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,774
yes,forgot to tell new parts in vehicle,maf,wires,plugs,coils,tps,fuel regulator,fuel pump,filter,crank sensor,and oxygen sensor.
__________________
I created you,I love you,don't love me? burn in hell forever. sounds like a human
Reply With Quote
  #6  
Old 12-16-2014, 07:09 AM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,774
can a coil fail after a years use.
__________________
I created you,I love you,don't love me? burn in hell forever. sounds like a human
Reply With Quote
  #7  
Old 12-17-2014, 01:56 PM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,774
found problems,spark plugs carboned,air leak after MAF,air filter leak.Karlyn spark plug wires are crap.

__________________
I created you,I love you,don't love me? burn in hell forever. sounds like a human
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page