Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-20-2015, 10:37 AM
Registered User
 
Join Date: Feb 2015
Posts: 2
300E Hesitation just before warm

1987 300E

Don't drive the car all that much but the last couple of weeks I've been having an issue. Upon a cold start the car runs fine, normal, idle smooth, acceleration good, etc.

Just before it the temp gauge shows fully warmed up coolant (just below 80C on the gauge) one of two things happens. If I'm just cruising along the engine with stutter for a few seconds (lose RPM and act like it's running rough), then corrects itself (maybe repeating a time or two) and run fine the rest of the trip. If I have to stop at an intersection right as it hits this point all will appear and feel right...until I go to move again. Then I get a major stumble from the engine, to the point of the engine shutting off about half the time. It restarts with a bit of cranking (more than a usual start up though). This may repeat at the next light (30-50 seconds away) but then it runs well till the next full cold start.

I'm thinking it has to be related to a coolant temp sensor failing but am open to other thoughts. Ideas?

Thanks for your input!
Reply With Quote
  #2  
Old 02-20-2015, 01:20 PM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 2,970
Experienced the same problem with a 1991 300CE (104 engine) and a new Oxygen sensor resolved the problem.
__________________
Fred Hoelzle
Reply With Quote
  #3  
Old 02-20-2015, 01:33 PM
Registered User
 
Join Date: Feb 2015
Posts: 2
I would hope that isn't my problem as the O2 sensor is less that 15K miles old, though I will test it to be sure.

Any other ideas?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page