Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 03-30-2015, 08:33 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Sounds like a failing fuel pump unit to me....especially if it sat on a lot for several months with untreated fuel....gas vehicles strongly dislike that especially with today's water absorbing ethanol mixed fuels....keep in mind that fuel pump is 14+ years old.

You could try running a tank with a heavy duty dose of Liquimoly fuel injection system cleaner through it...the stuff works very well!
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page