Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-30-2015, 03:15 AM
Registered User
 
Join Date: May 2008
Location: San Mateo, CA
Posts: 84
1995 E320 Wagon - CEL Issue

Hi Folks,

The CEL came on and I pulled the following codes.....

DTM
Code 2 - Heated Oxygen Sensor Faulty
Code 5 - EGR Faulty
Code 12 - Heated Oxygen Sensor Heater Circuit open or short circuit

Pin 8
Code 11 - O2S1 Heater (before TWC) Current too high or too low.
Code 39 - EGR Switchover valve - open or short ground or B+

Pin 14
No codes

I'm assuming that my 02 sensor is not working properly and needs replacing. The DTM code 5 and code 39 has been on/off after resetting and it showed up again without reason. Code 5 and Code 39 has been a reoccurring issue for quite a while. I just passed smog a couple of weeks ago . FYI. Any insights is greatly appreciated. Thanks!
__________________
---------------------
200 75 W115 (Mom's)
190e 90 2.6 W201
E320 95 Wagon W124
72 BMW 3.0 CSI
Reply With Quote
  #2  
Old 03-30-2015, 06:47 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,226
Code 5 is attributed to a plugged EGR tube.

Tube runs from right hand side (exhaust manifold) behind the head to under the intake.

The carbon cokes up at the intake end of the tube.

Some people have had luck running a speedo cable chucked into a drill to clear the obstruction. I didn't. I think that stuff is harder than diamonds.

I pulled the tube at both ends and cleaned it out. No light since.

Jim
__________________
14 E250 BluTEC black
05 E320 CDI Platinum blue
00 C230 Sport Brilliant silver (daughter's)
94 E320 Cabriolet Emerald green
Reply With Quote
  #3  
Old 03-31-2015, 11:14 PM
Registered User
 
Join Date: May 2008
Location: San Mateo, CA
Posts: 84
Yes, I have done that already and its clear. No carbon buildup. I'll change the switchover valve and see what happens. Thanks.
__________________
---------------------
200 75 W115 (Mom's)
190e 90 2.6 W201
E320 95 Wagon W124
72 BMW 3.0 CSI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page