Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2002, 07:46 PM
LAFetner
Guest
 
Posts: n/a
'92 300E, "Glowing" Warning Light, Water Level

I searched around and didn't find this specific issue, but seem that it would be fairly common.

I have '92 300E. Recently, the warning light for a Low Water Level came on. I checked, and the water level was definitely low. Topped off water appropriately. But, now the warning light isn't on, but it is still "glowing". It seems to be on about 10-20% of what it would be if it were ON. I have checked the level for a few days now, and seems fine...but light still glowing.

Any ideas?

Should this warning light be ON or OFF, and not glowing? If it is glowing, could the sensor be saying that the water level is very slightly low? I guess that I could add another bit of water to see if it goes off completely.

Thanks,
Novice MB Owner
Reply With Quote
  #2  
Old 04-29-2002, 09:19 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Should be on or off. There is no in between setting. I would suspect the level sensor is kaput. They do fail from time to time. Disconnect the plug, light should be off. Short the contacts in the plug, light should be on. If the glow disappears when you disconnect the plug, then it's your level sensor. if you need one, get it here, about $21.00 (cheap)
__________________
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
  #3  
Old 04-29-2002, 10:04 PM
Subman's Avatar
Senior Member
 
Join Date: Apr 2000
Location: South Florida
Posts: 447
I had a false reading like you on my coolant level. I took the connector off cleaned in and now it works perfect. I would suguest cleaning it before replacing it (there is no use wasting 21 bux)
Subman
__________________
Factory trained Mercedes-Benz Technician
Look At My Website
-2002 C32
(E420 has passed away)
The best way to contat me is e-mail.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page