Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2015, 02:50 PM
Registered User
 
Join Date: Jul 2004
Posts: 187
Noise from engine

I removed the multi belt and still have a noise getting worse when engine is hot no hard knocking sound and no whirr sound more like a pulley bearing but it is not because the belt is of.
Have not looked into it but what I will check tomorrow is if there is a loose spark lug or the damper from belt tensioner.
Timing chain? any other suggestions.
Car is a 1994 E320 high miles car m104 engine.

Reply With Quote
  #2  
Old 08-04-2015, 03:08 PM
mespe's Avatar
benzbonz
 
Join Date: Feb 2005
Location: Cleveland, Ohio
Posts: 1,848
It would be of considerable help if you recorded the sound and posted a youtube of it.
__________________
Closing the store
Benzbonz.biz
on your smart phone or tablet.
Reply With Quote
  #3  
Old 09-15-2015, 12:06 PM
Registered User
 
Join Date: Jul 2004
Posts: 187
Problem solved engine mount

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page