Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-30-1999, 09:02 PM
Nick Kotterman
Guest
 
Posts: n/a
My car (86 420SEL with 90,000 miles and FULL maintenance records) idles roughly and hesitates to pick up under low throttle. About mid throttle just off the line the power jumps in and gets the car moving. The shaking is most drastic at low or high temperatures, but around 75 degrees it is most subdued. Injector cleaner seems to help, but it is so subtle that it could be my imagination. I have replaced the the plug wires, and I am wondering if injectors are next. Or am I on the wrong track. Thanks for the help.

Nick
  #2  
Old 03-30-1999, 10:01 PM
M.B.DOC
Guest
 
Posts: n/a
Possibly you have a vacuum leak some where around the intake manifold. Has the fuel pressure been tested?? Fuel delivery (ie; injectors) can cause idle & accel. problems!

------------------
MERCEDES BENZ MASTER GUILD TECHNICIAN
ASE MASTER TECHNICIAN
27 YEARS M.B. TECH
  #3  
Old 03-31-1999, 11:32 PM
Benzmac
Guest
 
Posts: n/a
Does the engine have the old style steele injection nozzles? Or the new brass ones? The best way to check is with a magnet. The old injetion nozzles that are made of steele gave many problems.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle & the OVP.... gidpor Tech Help 13 01-07-2008 12:28 AM
E320 Rough Idle / Egr Problem earossi Tech Help 13 09-22-2003 10:14 AM
74 450SLC rough idle solved! deaconblues Tech Help 3 09-15-2003 01:23 AM
Rough Idle / Trans Modulator? awfrance Tech Help 5 07-08-2002 03:19 PM
W126 91 300SE rough idle revisited sixto Tech Help 0 02-20-2002 02:57 PM



All times are GMT -4. The time now is 08:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page