Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-05-2002, 10:49 AM
Posts: n/a
Cruise control surging

I have a 1986 560 SEL with a cruise control that works fine with the exception of "surging" when the car is going down hill. When it starts I disengage the CC, then activate it when the terrain levels out and everything is back to normal. I have checked the archives but can't find anything relating to this problem. Any ideas?
Reply With Quote
Old 05-06-2002, 09:33 PM
Registered User
Join Date: Jun 2000
Location: Near Williamsburg, Virginia
Posts: 358
I'd say it is trying to tell you that you are going to SLOW. 560's like triple digit speeds!
Reply With Quote
Old 05-06-2002, 09:35 PM
Posts: n/a
It may help to clean and re-lube the linkages between the cruise control and throttle. They get pretty gunked up. Pop them apart, clean them, and re-lube with ATF or similar light oil.

Some CCs seem to just surge when not under load. You can try pressing the accelerator slightly--that'll sometimes eliminate the surge.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page