Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-1999, 11:12 PM
K. Williams
Guest
 
Posts: n/a
My 1987 300 TD has a new problem. The fan for the climate control system works just some of the time. Recently I have tried to use the AC system, and the fan will not work in either low, auto or high-speed mode. Then when I go to park the car, the fan mysteriously begins to operate. At other times, the fan works fine.

Because, back in the winter, I got some funky performance from the defrost setting (fan would not come on but if I would jiggle the button for the defrost, it would) I am suspicious of the pushbutton control unit. Ideas about what else could be causing these problems?
  #2  
Old 04-02-1999, 11:48 PM
Benzmac
Guest
 
Posts: n/a
Try cranking the car and if the fan doesn't come on turn the key back a littttttle bit. Not enough to turn off the engine. If the fan comes on the electircal portion of the ignition swich is faulty..I have seen this many times.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Notes may help people: Radiator, Fan Clutch, Temp Sensors, Fuel Pump, Temp Gauge ericgr SL Forum 3 09-24-2004 02:40 AM
climate control fan speeds papag4god Tech Help 1 07-14-2003 06:09 PM
Page # for climate control on factory CD 300TD4x4 Diesel Discussion 0 02-19-2003 06:24 PM
Climate control unit '88 260E robbysf Tech Help 1 09-16-2002 01:39 PM
W124 climate control... fan surges mgelber Tech Help 3 12-31-2001 09:07 AM



All times are GMT -4. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page