Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-22-2016, 09:04 PM
Registered User
 
Join Date: Aug 2016
Posts: 2
Angry 1986 mercedes 300 e class

Barn find. sat for a number of years full of gas. had to replace fuel pump and filter. hard starting. have to crank a long time when it does start runs rough for a bit then idles up to 1500 and wont idle down.Drained all gas and filled with 91 octane. what could make it act like it is? also put in new spark plugs. Really sharp car if I can make it run. 250000 miles, don't smoke. any ideas?

Reply With Quote
  #2  
Old 08-23-2016, 09:23 AM
optimusprime's Avatar
Trevor Hadlington
 
Join Date: May 2014
Location: Worcestershire in England
Posts: 1,295
My bet would be vacuum leak .Check all small pipes and the conectors for splits. Under the air filter you will see a part with a conection on the rear ,its held in with a saddle and 2 screws ,on the rear it will have 2 hoses remove them and wash it out with white spirits or carb cleaner Then replace it .Also the top of the throttle plate ,spray this also with carb cleaner.. Next check all fuses ,the ends go white with corrosion and dont make contact. Give them a twist in the holders .Then all earth points want cleaning 90% of electric problems are earth related.Remove them clean and a little grease on the end , now pop the screw back in the end and lock it up. Come back after you have done this. As i now a few more things you can try out . One thing first ,spray the top of the injectors seals with Wd40 fluid see if it changes the speed of the engine..If so the seals have gone in the fuel injector seats .
Reply With Quote
  #3  
Old 08-23-2016, 11:54 AM
Registered User
 
Join Date: Jul 2011
Location: bellevue, wa.
Posts: 106
Check the overload protection relay.
Reply With Quote
  #4  
Old 08-23-2016, 01:27 PM
Registered User
 
Join Date: Mar 2003
Location: Southern California
Posts: 2,154
Check nearby threads on hard starting/rough initial running issues.

Duke
Reply With Quote
  #5  
Old 08-23-2016, 01:33 PM
bsmuwk's Avatar
124.051
 
Join Date: Jan 2009
Location: IL / WI
Posts: 950
What to do when my M103 is giving me trouble: A beginners guide ~ Artisan

__________________
-Allen
Lakemoor, IL
Artisan Motorenbau
Chicagoland Mercedes Enthusiast Facebook Group: https://www.facebook.com/groups/mbclubchicago/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page