Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-07-2016, 06:38 PM
Registered User
 
Join Date: Sep 2016
Posts: 1
Help with new to me 1991 190E 2.6 Poor throttle response *Video*

I used to be a member of this forum, but I can't seem to remember my original login information. Anyway, long story short, I picked up a clean little 190E 2.6 yesterday for practically nothing. Everything seems to work on the car, the transmission shifts well. But the acceleration is really bad, and almost wont even go at all once its warmed up. I am prepared for the possibility that the engine is just dead, but it idles nicely and doesn't sound all that bad. When you hit the gas, the engine very slowly responds. It's got a bit of ping when you hit the gas much at all. Today I have just been slowly cleaning the engine bay, getting acquainted and cleaning all wire contacts, and checking vacuum lines for obvious cracks, etc.

In the video, both times I hit the gas full throttle. The response is just that bad.
https://www.youtube.com/watch?v=DmY8hTSiFe4

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page