Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2016, 10:50 AM
Registered User
 
Join Date: Feb 2016
Posts: 43
Turn signal and headlight problem

Its like murphys law with my car now, just yesterday the right turn signal stopped working. If you hold the stalk up all the way it'll work but if not holding it, it'll not work. When key is in accessory there is a audible beeping from the fuse area when the right turn signal indicator is on(not working though) but if held up to make it work, the beeping goes away. Also my low beams haven't worked for a while now

Reply With Quote
  #2  
Old 09-25-2016, 12:26 PM
Registered User
 
Join Date: Sep 2001
Posts: 967
What year make and model?

Sounds like turn signal stalk is bad re: turn signal.

Beeping could be dirty fuse connection, my 124 did this when applying the brakes.

Low beams??? are the bulbs proven good? Might be bad bulbs.

Good luck and keep us posted...
__________________
Does a Caddy stretch? No, but a Mercedes bendz.
Reply With Quote
  #3  
Old 09-25-2016, 12:26 PM
babymog's Avatar
Loose Cannon - No Balls
 
Join Date: Jan 2006
Location: Northeast Indiana
Posts: 10,767
Is this on a car, truck, ute, ...?
__________________

Gone to the dark side

- Jeff
Reply With Quote
  #4  
Old 09-26-2016, 12:39 AM
Registered User
 
Join Date: Feb 2016
Posts: 43
Its a 1989 190e 2.6
Reply With Quote
  #5  
Old 09-26-2016, 01:57 PM
DieselGuy53's Avatar
Registered User
 
Join Date: Feb 2007
Location: Maryland
Posts: 274
Quote:
Originally Posted by Sugar Bear View Post
What year make and model?

Sounds like turn signal stalk is bad re: turn signal.

Beeping could be dirty fuse connection, my 124 did this when applying the brakes.

Low beams??? are the bulbs proven good? Might be bad bulbs.

Good luck and keep us posted...

Time to R&R turn signal stalk...BTDT.
__________________
1987 300SDL 314K mi, counting; #22 Head
1999 E300Turbo 405K original miles
1997 E320 180K mi (Son's)
2002 ML320 (Son's)
1998 S320 140K mi (Son's) sold
1985 300SD 311K mi
1984 300D 324K mi (killed by a hit-n-run turd)
*************************************
Reply With Quote
  #6  
Old 09-26-2016, 02:25 PM
Registered User
 
Join Date: Dec 2002
Location: New Castle County, DE
Posts: 1,041
Before you delve into R&R, "twirl" all the fuses. This is a yearly contact cleaning maintenance item not found in the manual . If this doesn't fix it, check the fuses. Not a visual but an electrical check with an ohm meter. "they look OK" isn't good enough. This should get the electrical part working. The having to hold the lever part is going to involve R&R.
__________________
Hanno
'79 6.9 Sold (after 27 years of ownership)
'83 280SL, 5 spd.
'94 E320 Sdn. 5 spd conversion
'95 E320 sedan
'02 E320 Sdn.(on loan to mom!)
'87 300E (5 spd. conversion) Sold
'05 E500 Wagon
Reply With Quote
  #7  
Old 09-27-2016, 09:16 PM
Registered User
 
Join Date: Feb 2016
Posts: 43
Replaced the stalk, fixed the problem. Thanks guys

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page