Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-11-2016, 02:34 PM
Registered User
 
Join Date: Dec 2016
Posts: 1
Instrument cluster not working after dead battery

My 2011 SLS AMG battery went dead and after jumping the car and getting it started, my instrument cluster (speedo, tach, digital) doesn't come alive or show. The battery was trickle charged over night and the car now starts, but cluster doesn't come on. My center console, navigation and radio do work. My front and rear lights do work.

HELP!!!

My email is jexpo1128@yahoo.com

Thx

Juan

Reply With Quote
  #2  
Old 12-15-2016, 03:47 PM
86560SEL's Avatar
Registered User
 
Join Date: Jan 2003
Location: east Tennessee (southeast USA)
Posts: 3,015
Quote:
Originally Posted by Jexpo2016 View Post
My 2011 SLS AMG battery went dead and after jumping the car and getting it started, my instrument cluster (speedo, tach, digital) doesn't come alive or show. The battery was trickle charged over night and the car now starts, but cluster doesn't come on. My center console, navigation and radio do work. My front and rear lights do work.

HELP!!!

My email is jexpo1128@yahoo.com

Thx

Juan
I imagine you have already checked for any fuses that may be blown? Alot of strange things sometimes happen to some cars when they are boosted off (and to the ones doing the boosting).

Good luck!

__________________
2004 Toyota Sequoia Limited 4wd
1991 Lincoln Town Car Executive
1991 Cadillac Sedan DeVille
1988 Mercedes 300SEL
1972 Chevrolet Caprice Kingswood Estate 9-passenger wagon
1973 Pontiac Grand Ville
(Prior MB's: 1974 240D, 1985 380SE, 1984 190D, 1993 400SEL)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page