Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2017, 04:30 PM
Registered User
 
Join Date: Aug 2005
Location: Toronto
Posts: 394
'04 E320 Dead Instrument Cluster

My '04 E320 wagon has a dead instrument cluster. At first the instruments started resetting, the whole cluster would go dark while driving then immediately power up, the clock would reset by turning backwards. Occasionally the gauge cluster would be dark right after starting the car then it would power up after a minute or two of driving, reset clock and would be fine for a day or a few days. Now it's completely dead, no gauges, idiot lights or instruments ever.

So far I have:

Tested/charged main and auxiliary battery - batteries are good
Looked at central gateway for corrosion on connections - none
Looked at all the fuse panels, pulled fuses and re-seated, checked for corrosion - all seem OK

I have spent some time online researching but haven't found much in the way of conclusive info an where to go next. Was considering buying an icarsoft i980 scanner to help diagnose but not sure if that will help?

Any suggestions welcome.

__________________
________________

punkinfair
Reply With Quote
  #2  
Old 02-12-2017, 08:56 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,364
If the instrument cluster has power and its dead, then its time for a new instrument cluster. AFAIK, new from MB is the only option as the replacement cluster has to be married to the car before it will work.
__________________
90 300TE 4-M

Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #3  
Old 02-13-2017, 11:00 AM
Registered User
 
Join Date: Aug 2005
Location: Toronto
Posts: 394
I will probe the harness of the instrument cluster for voltage and see what I find. Research says two other places to look related to battery power fault, a Battery Relay that is beneath the windshield shrouding, and a battery Control Module in the back. I can see both of these units but there is trim to be removed in order to test/inspect them.

For a new cluster the only option seems to be the dealer. Cost for a new cluster is CAD $1,125.00 list, plus the labour to code it.

I have a related question for folks who might know - seems like it is possible to replace the cluster, central gateway, and two other boxes, and have everything work?

__________________
________________

punkinfair
Reply With Quote
  #4  
Old 02-13-2017, 01:15 PM
Registered User
 
Join Date: May 2012
Location: El Dorado Hills, CA, USA
Posts: 418
Open up the cluster, and change the big electrolytic capacitors. It is usually the problem on these cars.

To go through the other monkey business is non-sense..

Martin
Reply With Quote
  #5  
Old 02-13-2017, 01:22 PM
Registered User
 
Join Date: Aug 2005
Location: Toronto
Posts: 394
Thanks, will look into that. Also, found out you can swap the large board from back of cluster to a replacement cluster and no coding or swapping of other components required.
__________________
________________

punkinfair
Reply With Quote
  #6  
Old 02-13-2017, 02:09 PM
TX76513's Avatar
Platinum Member
 
Join Date: Apr 2003
Location: Brandon, Mississippi
Posts: 5,203
Have you spoke with James at MB Cluster?

James Kouramanis
8 Blacktoft Drive
Scarborough, Ontario
M1B 2M6 CANADA
Telephone:
(416)724-2149
__________________
BENZ THERE DONE THAThttp://www.peachparts.com/shopforum/...c/progress.gif
15 VW Passat TDI
00 E420
98 E300 DT
97 E420 Donor Car - NEED PARTS? PM ME!
97 S500
97 E300D
86 Holden Jackaroo Turbo D
86 300SDL
(o\|/o)
Reply With Quote
  #7  
Old 02-13-2017, 02:14 PM
Registered User
 
Join Date: Aug 2005
Location: Toronto
Posts: 394
No! Great source, thank you!
__________________
________________

punkinfair
Reply With Quote
  #8  
Old 02-14-2017, 01:03 PM
Registered User
 
Join Date: May 2012
Location: El Dorado Hills, CA, USA
Posts: 418
James at MB Cluster is a very smart guy, yet I have never sent a cluster to him, but he knows what he is talking about... Go with him if you got butterflies with the capacitors..

Martin

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page