Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-24-2002, 02:32 PM
ullrich
Guest
 
Posts: n/a
brake fluid reservoir properly flushed, or not?

Had the brake fluid of my 86 300SDL flushed by the local M-B dealer.

Afterwards, looking at the reservoir, I noted that the new fluid at the front of the reservoir was water-clear, but that the rear section was amber in color, indicating old fluid still remaining.

Dealer said this was normal, but I have my doubts as over the years I have never seen this before.

It occured to me that both sections of the reservior should be clear as new fluid is pushed into it by their pressurized flushing system.

Should I go back and have the job redone, or is what the service rep said valid? I would like to believe him, but the results do not make sense to me.

Any answers?? Thanks, Jack Ullrich
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page