Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #31  
Old 08-28-2017, 02:03 PM
Jorn's Avatar
Registered User
 
Join Date: Nov 2003
Location: TheFlyingDutchManInHollywood
Posts: 4,600
If the brushes of the voltage regulator looked like this they needed to be replaced.

__________________
Black on Black 1979 300CD (sold), 1990 Black 300SE, Silver 1989 Volvo 780 Bertone...
Reply With Quote
  #32  
Old 08-29-2017, 12:21 PM
ChrisArnt's Avatar
Registered User
 
Join Date: Dec 2009
Posts: 279
Quote:
Originally Posted by Jorn View Post
If the brushes of the voltage regulator looked like this they needed to be replaced.

Yes. They looked pretty much just like that.

I hope this fixes the problem.
__________________
~~~~~~~~~~~~~~~~~~~~~~
You play nice and so will I.
Chris NJ
96 E300D, 71 Baja Beetle, 77 Convertible Beetle, 2003 Subaru Forester.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page