Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-16-2017, 04:58 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,833
95 E320 odometer stopped working

My odometer just stopped working, along with the trip odometer. I could get it working for a bit by resetting the trip odometer, but after my 300 mile trip today it just won't work at all. Has this happened to anybody? Does it need a new odometer, or should I be looking at the cable feeding it?

__________________
95 E320 Cabriolet, 153K

Last edited by Kestas; 10-03-2017 at 07:09 AM.
Reply With Quote
  #2  
Old 09-18-2017, 12:33 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
The speedometer/odometer died on mine a ways back; tach death occurred shortly after that.
Research reveals my speedometer is electronic and has no cable. Your car is 4 yrs. newer than mine; I'd bet a buck yours is also electronic.
There are threads on replacing the small plastic gears inside the speedometer and others that indicate the problem can be more electronic in nature vs. mechanical.
There are posts on this forum that show a couple of speedo/tech repair shops in California and a guy in Austin, Tx. who is highly touted all over the web. I spoke via email with the Tx. guy - he didn't seem to be too high on fixing the tach.
I prefer one-stop shopping, so when I get around to fixing mine they will likely get to visit the Golden State.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #3  
Old 09-20-2017, 07:32 PM
Administrator
 
Join Date: Mar 2016
Location: Los Angeles, CA
Posts: 1,830
Quote:
Originally Posted by Kestas View Post
My odometer just stopped working, along with the trip odometer. I could get it working for a bit by resetting the trip odometer, but after my 300 mile trip today it just won't work at all. Has this happened to anybody? Does it need a new odometer, or should I be looking at the cable feeding it?
Hello - take a look at the link below to an earlier thread where this is discussed. I believe that there is a procedure guide link in the thread as well. Hope this helps and best of luck!

W124 odometer
Reply With Quote
  #4  
Old 09-20-2017, 08:20 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,833
Thanks. That's what I was looking for. Next step is to remove the gauge to see what is broken.
__________________
95 E320 Cabriolet, 153K
Reply With Quote
  #5  
Old 09-30-2017, 04:47 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,833
I removed the speedometer/odometer unit. It is different from the one in the link provided. It appears I need to take the face off the which involves removing the needle to get to the odometer. Is this true? I'd rather not mess with the needle if I don't have to.
Attached Thumbnails
95 E320 speedometer stopped working-image.jpg  

__________________
95 E320 Cabriolet, 153K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page