Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-21-2017, 11:51 AM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
E320 w210 a/c blower works! Then it fades away slowly

Hey guys back here again reporting an issue on my auction buy of a 2001 E320 sedan. I picked it up yesterday in Atlanta and boy it was hot outside! I was sad when I cranked the car to see that the air conditioner would not come on. The compressor was not turning and the blower would not blow. But the display did light up and all the functions seem to work. There was just no action .

Today this morning I get in it crank it up and the air conditioner fires right up and is blowing extremely cold air! The compressor was running full time. However after about two or three minutes as the car warms up the blower just starts to fade out until nothing comes out at all. I have had a lot of AC woes with my Benz is over the years but I have never experienced this issue.

Has anyone had any experience with this? If so does anyone have an idea of where or what I should check first?

Thanks in advance for any help that anyone can provide have a great day!

__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #2  
Old 09-21-2017, 12:16 PM
Registered User
 
Join Date: May 2009
Location: The slums of Beverly Hills
Posts: 6,451
You need to replace blower motor controller located inside the passenger side dash board. The controller is about $25 on eBay and about 1 hour of work. Have your torx tools ready.
https://mbworld.org/forums/e-class-w210/153918-early-w210-blower-motor-regulator-replacement-diy-here.html
I think ur 01 falls under the late design so the components looks slightly different.
Reply With Quote
  #3  
Old 09-21-2017, 12:52 PM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
Aw man thx tjts! I did this job earlier in the year on my e420 But I guess since this car is a 2001 the regulator will be the the newer one? Right? If it is no worries thx to your diy link. You saved the day! I am knee deep in cleaning this car today. Prev owner was a coal miner . Lol.
__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #4  
Old 09-21-2017, 12:54 PM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
Oh and one more thing. I will start a new thread if I need to. I noticed driving home last night only my two inside round headlights worked. The two larger outside oval lamps did not work. The blinkers work inside of them. However both bulbs must be burnt out! I hope that is the problem. It just seems weird that the previous owner would be too lazy to replace the lightbulbs. I'm curious if there is an electrical problem. I will dig in and see what I can find out thanks again for your help. And the blower regulator link. much obliged
__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #5  
Old 09-21-2017, 07:29 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,583
You will, in all likelyhood, find the insulation cracked and broken up on the headlight wiring inside the headlight assemblies. In regards to the climate control unit it is as tjts1 has stated with the issue being in the blower/resistor assy. My solution was to purchase a good, used blower/resistor assembly that had the upgraded resistor. I think it was $85 off fleabay. Pricing from your friendly MB dealer will make your jaw drop.

With the car running if you mash and hold down on the rest button of the climate control push button unit you can get into it and get all kinds of good information out of it. Do a search to see what all the different numbers mean. The main ones are 5 and 7 in my opinion. The positive in your case is that you did get cold air out for a period of time. That means the refrigerant circuit is charged/operative.
__________________
Jim
Reply With Quote
  #6  
Old 09-23-2017, 08:17 AM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
Thank you guys! Thx Jim for the info. I was at oreillys picking up some supplies and got a quote for the blower resistor......$282. Lol. No thx
__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #7  
Old 09-23-2017, 06:26 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,515
If this is like the 97 era W210 / W202 / R129 , that isn't a resistor for the blower, it is an electronic speed controller. ( sort of like a dimmer for a house light )

Before changing you need to monitor control voltage ( with a meter and looking at on board data ) and see if it is falling off. If it is, there is a problem with the in dash HVAC control. There are ways to pull data and codes from the HVAC by pushing buttons on 97 era cars, not sure about 01.
Reply With Quote
  #8  
Old 09-24-2017, 06:03 AM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,583
I've always considered it a "resistor" for lack of a better term.
__________________
Jim
Reply With Quote
  #9  
Old 09-25-2017, 10:43 AM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
Thank you! I did pull codes from the HVAC. Problem is my display has lost pixels on the right side. I was only able to make out the first code E61 234 which appears to be for the "sun sensor". Looks like there were 2 more codes that followed but again I could not make them out
__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #10  
Old 09-25-2017, 11:46 AM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 910
Well since putting the HVAC in test mode it works all the time now. BUT it dies off as you accelerate and blows strong as your cruising. Even the slightest throttle input at freeway speeds causes the blower to fluctuate . Now that's a new one on me.
__________________
Current stable......
17' rogue SV 35k
08 9-3 SportCombi 150k
02 e320 210k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #11  
Old 09-25-2017, 12:09 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,515
The 97 era cars used engine vacuum to operate the HVAC flaps. This was a ~ 1/8" white nylon tube that ran across the engine to the passenger side computer box. I'm not sure what yours has.

Check the defroster outlets, default is air from the defroster.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page