Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-03-2002, 01:58 PM
mbz380se
Guest
 
Posts: n/a
M116 380SE noise upon startup...timing chain?(couldn't find any help in the archives)

Alright...

This morning, my dad started the 196K mile '85 380SE, and it started, with a "rattling" sound from the engine. He immediately shut it off, thinking the noise sounded expensive. Would anyone have ANY idea what this could be?

I'm hoping (and kind of doubting) that it is the timing chain, after all, this car does have 196K miles of many road trips. I think the chain would have busted long ago if it was the original setup. Yes, and as you all know, this car has double-row timing chains.

Any help would be greatly appreciated.

-Sam
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page