Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-07-2002, 12:18 AM
colombo
Guest
 
Posts: n/a
flasher relay

My 1995 e320 has had flasher/hazard/intermittent wiper problems. Basically all of the above come and go. I figure it is the combo relay, but I don't think the part has failed because all of the above work about 40% of the time. I checked the relay -- it seems to not sit tightly in its socket. If i wiggle the relay, i can get the flashers to both work and not work. Will the problem likely be fixed with a new relay in the same socket? Does it matter if my temp. fix is a piece of paper towel jammed between relays to hold this one tightly in place? Don't know if that is safe or not, but it seems to do the trick.

Thanks in advance.
Reply With Quote
  #2  
Old 06-07-2002, 04:53 AM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
try swapping the relay with another and see if it fits tighter. if not, you maybe to to modify the socket a bit by trying to tighten the connectors that attach to the relay.

It may also be a loose wire in the wiring area below the relay

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #3  
Old 06-08-2002, 10:39 AM
MB FRAU's Avatar
Registered User
 
Join Date: Feb 2002
Location: Indianapolis
Posts: 39
Colombo-

The same relay on our '93 400E began acting up over about a 4 month period and one day just finally died. We made the replacement and all has been fine since.

Since you have an issue with the relay being loose follow Ashman's advice and swap it out if you can. That is what we did before getting the replacement just to make sure we were replacing the correct part. (that's one of the benefits of having two cars with "some" of the same parts!)

MB FRAU
__________________
Joint Owner of:
'93 400E (80k miles)
- Smoke Silver/Parchment
'93 300CE Cabriolet (43K miles)
-Midnight Blue/Parchment
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page