Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-07-2002, 03:53 PM
Registered User
 
Join Date: Jun 2002
Posts: 14
86 300sdl, slow acceleration

Car takes about 20 seconds to get to 60mph. How do check if the turbo is working and system to controll is working? Anything else I should check?
Reply With Quote
  #2  
Old 06-07-2002, 08:34 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,744
Clean the line from the intake manifold to the ALDA on top of the injection pump.

Temporarily bypass the overboost switch. Sometimes the boost sensor sticks.

Check that the air recirculation thing under the EGR valve isn't stuck open. A quick check is to plug the line to the recirculation valve. That doesn't help if the valve is physically stuck open, though.

Sixto
91 300SE
87 300SDL
Reply With Quote
  #3  
Old 06-07-2002, 09:23 PM
Registered User
 
Join Date: Jun 2002
Posts: 14
What is

Alda? If I do all this, does this mean the Turbo is in need of replacing? Can they be rebuilt?
Reply With Quote
  #4  
Old 06-08-2002, 03:28 AM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,744
Simply giving these Diesels more air does not increase power output. The ALDA is the anaeroid (sp?) compensator that instructs the injection pump to provide more fuel under boost.

One thing I forgot to mention was to hook up a boost gauge to one of the nipples on the intake manifold. If you see boost, then the problem is not with the turbo. You'll have to test this with a load on the engine such as while driving the car. Reving the engine in neutral will not create boost.

I believe the turbo can be rebuilt and obviously it can be replaced.

Sixto
91 300SE
87 300SDL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page