Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 05-04-1999, 01:00 AM
Posts: n/a
I am considering buying a 1984 190E. My only concern is that the engine has a tapping sound that increases in speed as the idle goes up. The salesman says this is normal. Is it? or is it something that might need major repair? Otherwise, the car runs great. pickup is quick and it seems to have a lot of power. It also idles smoothly. Any feedback would be greatly appreciated.
One more thing that I noticed while test driving this car is that the first time I went to use the directional, nothing happened. I turned on the hazard lights for a second and then tried the directional again and it worked. Just a fluk? or electrical problems? As you can probably tell, this is going to be my first Mercedes, I've always driven caddies but I fell in love with this 190E when I saw it on the lot.

[This message has been edited by John4m (edited 05-04-99).]
Old 05-04-1999, 07:20 AM
Mark Herzig
Posts: n/a
I had this problem after I had my valve stem seals replaced on my '86 300E; I think it was just coincidental, however. It turns out that one of the lifters was stuck and so I had it replaced and all runs well. I think the part was about $30.00/or so.

Wait for one of the technical guys to comment however as I am a novice who trys to find quality car car at bargan prices!
Old 05-04-1999, 11:30 AM
Posts: n/a
My 190E is having the same problem, sometimes
if I turn on/off the harzard light, the
directional will then failed. Try a few
on/off the harzard lights, it's then back
to normal again. I think it is due to the
harzard switch contact problem. Anybody
got a better idea ?
Old 05-04-1999, 12:48 PM
Posts: n/a
You may have bad hyd lifters or cam shaft have some one check it for you.
Hazard switch is possible or the relay ?
Old 05-04-1999, 09:27 PM
Posts: n/a
If the hazard switch isn't fully depressed in the off position, the blinkers will not operate. The 1984 190E was the first year of production and I thought they were not very good cars. I don't like to see them in my shop. Try for 1988 or newer(double row timing chain).


Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1984 190E Mercedez Engine turn off suddenly when driving long distance Maqsood Tech Help 0 11-05-2003 03:44 AM
Important Question 190E 2.3 1984 Benz84 Tech Help 2 05-17-2003 11:12 AM
1984 190e 2.3l Pilotx1 Performance Paddock 0 10-07-2002 01:54 AM
1984 mercedes 190e 2.3l Pilotx1 Tech Help 10 04-28-2002 08:39 AM
1985 300CD with a 1984 Engine? Dcraig Diesel Discussion 7 10-15-2001 11:51 PM

All times are GMT -4. The time now is 01:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page