Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 05-04-1999, 12:18 PM
Posts: n/a
I have the following problems regarding my 190E and I appreciate if you could share some opinion/advise.

1. The engine have no problem in starting and high RPM, but when idling, it is a bit rough at around 800 RPM, it seem like miss fire once a while. I have replaced the spark plug and vacuum hose under the air filter.
but no luck. Initialy, I though it was due to air cond engage but this happen even the air cond is off. Any advise what else to look for ?

2. How do I check/ensure the engine mounting is bad? I was told there are 2 types of mounting (round and square). Is 190E using
the round type ?

3. The engine oil level drop 1/4 after about
3000KM travel, and I hardly notice any white smoke from the exhaust. Confirm no leakage.
Actually, the car was left for about a year without start. Could it be the ring is jam ? Should I add some oil treatment to improve
it ?

Thanks in advance.

Old 05-04-1999, 12:39 PM
Posts: n/a
First I will check the spark plug wire set ?
motor mount on 190 only have one type is round hyd mound......How u check put a 13mm bolt on side of motor mount if u can put the bolt under the mount that mount is good if not replace it or check is any hyd fluid leaking from the mounts if leaks replace it.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.3-16 parts for sale kiato4 Mercedes Used Parts For Sale & Wanted 2 06-25-2003 07:14 PM
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 10:25 AM
Water pump, engine mounts, tensioner shock 190E? sbourg Tech Help 5 01-23-2003 04:21 PM
Engine swaps for a 1990 190E 2.6 190E_V8 Performance Paddock 15 11-14-2001 05:10 PM
190E 16V Computer/Sensor Problems SCBauman Tech Help 6 06-08-2001 08:31 PM

All times are GMT -4. The time now is 04:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page