Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-13-2002, 09:23 PM
ullrich
Guest
 
Posts: n/a
blinker on the fritz

on a 86 300sdl the blinker will blink 2-5 times and then stay on.
Next time it will work again for 5 seconds. Have been told to clean the hazard switch as it is part of the multi purpose relay #201 821 0247 setup and that corrosion there might be the culprit. Nothing worked. I hate to pay $151 for a new relay to find that it was not the cause of trouble. As far as I know it cannot be sent back even it if was used for only a few seconds. M-B will only tell you to bring the car in, and for mucho dollares.
Any thoughts out there???
Reply With Quote
  #2  
Old 06-14-2002, 11:32 AM
Former Dieselholic
 
Join Date: Feb 2002
Location: West Michigan
Posts: 380
ullrich,
This may be a long shot, but here is what I did on my 81 300TDT:

This car was in an accident and the drivers side headlight assembly was totally crunched.

After replacing the assembly, I plugged the lights back in and found that the turn signal would not blink-but it came on- or sometimes it did not come on at all. (It blinked real fast b4 I replaced it...)

So I check the connections at the turn signal bulb holder and everything *looks* OK. I try another bulb, nothing. I then try to open the little box at the end of the plug to see the actual connections (If this is confusing, I will post pics) and one of the wires had come loose. Re-soldered the connections and BINGO good as new.

It's worth a shot.
__________________
Current: '91 300TE 4MATIC 317k and climbing...
Former:
'81 300TD Wagon 168K "Tank"
'83 240D 216K 4spd manual "Da Bear" (aka best car ever)

"Never sweat the petty things...
and never pet the sweaty things."
Reply With Quote
  #3  
Old 06-14-2002, 06:12 PM
Bear's Avatar
Registered User
 
Join Date: Jan 2002
Location: London,England
Posts: 495
Ullrich,had the same problem on my 82 300D,make sure the relay is in securely they do wriggle loose sometimes.Instead of going to a dealers try picking up a spare from a breakers.Bear
__________________
W123 '82 300D red 202,000 miles

G460 '83 280 GE LWB 69,000 miles

Mercedes-Benz Club member
http://www.mercedes-benz-club.co.uk/

S Klasse Club Deutschland
http://www.s-klasse-club.de/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page