Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-19-2002, 01:25 AM
Posts: n/a
'85 190E Recent Starting Problem

My 1985 190E 2.3L has become very difficult to start recently. The #1 spark plug is burning clean. #2 & #4 are covered with dry carbon. However, #3 had a chunk of the ceramic burned off and was covered with carbon. 92 octane gas. Distributor and rotor are O.K. Fuel does not seem to be getting through. Do you folks think the fuel pressure regulator on the 190E needs to be replaced? Once I do get the engine running, it runs fine. Hot starts are O.K. Cold starts are difficult and seems to sputter for more fuel.

Reply With Quote
Old 06-22-2002, 12:59 AM
Posts: n/a
Replaced fuel pressure regulator and starting problem is fixed.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page