Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-20-2002, 11:23 PM
Eddie16V
Guest
 
Posts: n/a
190e-16v

All four Power Windows do not work, they work early in the day. I check the fuses they seem to be fine. I did replace one fuse with new one on one side, still doesn't work. Any ideas?
Eddie16v
Reply With Quote
  #2  
Old 06-21-2002, 05:02 AM
Brian16V
Guest
 
Posts: n/a
Had the same gremlin awhile back, but only one window. Didn't do anything, but one day it seemed to work fine. Has been fine ever since. Tho' I only drive the car once per week, while parked in the garage I keep all 4 windows slightly ajar (2"). Also, after pulling into the garage I'll fully cycle all 4 windows. As for your situation, you might want to try pulling a couple of the switches and clean the contacts (both the master driver's panel and each individal rear door switch). Or, purchase a new switch (they're not that expensive) and swap that one in and out.

Good luck!

Brian16V
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page