Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-28-2020, 02:18 PM
Registered User
 
Join Date: Apr 2008
Posts: 2
w212 issues please help

Please advise, my 2011 E63 AMG Mercedes Benz 49K mileage has some issues. One relay in the front SAM N10/1 marked location (N) continuously clicking whether the ignition is on or off. Second issue the engine will not crank/start. When I insert the FOB key, I am able to turn the key, the lights on the dash panel lights on, but engine will not crank. I am able to shift gears from Park, Reverse, Neutral and drive. I have tried starting engine while I shift the lever to neutral, still no crank. I have checked all the fuses in the front SAM and they are all good. When turning the key to start there is no clicking sound from the starter. Does relay (N) have any involvement for the non starting issue? My car battery is new, just replaced after having non starting issue. Is there a way to jump start the starter through the starter relay in the front SAM? Thank you in advance for your help. Hawthorne

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page