Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-22-2002, 09:10 PM
Registered User
Join Date: Aug 2001
Location: Ohio
Posts: 183
96 C280 Wiring Harness Problem?

I have been reading some threads on the wiring harness problem that has plagued some C280 models?

Is this a problem with the 96 c280 and how can I inspect the wiring harness?

Where does the shorts occur?

Martineau Gauda

96 C280 Mercedes
82 Rolls Royce Silver Spur
Reply With Quote
Old 06-22-2002, 09:12 PM
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,503
The wiring harnesses were bad from 93-95.

Looks like you're in the clear.
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page