Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 08-06-2002, 12:01 PM
Registered User
 
Join Date: Jul 2002
Posts: 57
my AC (87 190e) went bust a couple of weeks ago - while driving on the freeway, it started blowing hot air. After switching off and restarted, it engaged for a couple of seconds, then made a rattling sound and disengaged. I didn't try again. Then last week it didn't engage at all - now its totally dead, just blows regular/hot air. How can I check to see if the compressor is OK, or its seized up? My guy quoted me over a 1000 buckes for a new compressor and the works. Want to make sure the compressor is the problem before I sink in the money.

Thanks.
Reply With Quote
  #17  
Old 08-06-2002, 12:42 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,791
Try engaging the compressor again. If you get an awful sound, it's probably a bad compressor. Also, try rotating the back portion that mates to the clutch and see if it can be rotated by hand.
__________________
95 E320 Cabriolet, 140K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page