Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-12-1999, 04:31 PM
slk528
Guest
 
Posts: n/a
The right turn signal does not work when I have the headlights on. They do however, work when there are no lights on. Is there an electrical problem, or are the wires crossed??
  #2  
Old 05-13-1999, 12:28 AM
MB STARS
Guest
 
Posts: n/a
Did you check the ground wires ?
  #3  
Old 05-13-1999, 09:20 AM
slk528
Guest
 
Posts: n/a
You'll have to excuse my ignorance, but where are the ground wires? Battery ground?
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E headlight for sale like new 2.3 2.6 2.3 16v euroamg Mercedes Used Parts For Sale & Wanted 4 02-22-2005 07:27 PM
Question on Axle of w201 2.3 16V swib Tech Help 6 03-19-2004 08:57 AM
Help! Instrument panel dead, no turn signals Roger65 SL Forum 8 03-05-2004 11:48 AM
190e turn signals not working properly AMG Tech Help 5 12-01-2003 10:21 PM
2.3 8V air flow sensor work in a 16v daveCT Tech Help 1 02-19-2003 11:57 AM



All times are GMT -4. The time now is 06:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page