Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-23-2002, 10:05 PM
Registered User
Join Date: Jun 2002
Posts: 57
Question starting problem

In regards to my '89 420 SEL, I have had recent problems when attempting to start. The engine will turn over but will require an extended turn of the key. Once the car starts, it will idle roughly and shake for aproximately 20-30 seconds. Applying the gas lightly once the car starts seems to help the problem but is not a cure.
I have replaced the following parts in an attempt to correct the problem: spark plugs, wire set, distributor cap and rotor, fuel filter, O2 sensor, and air filters.
I have searched the archives and found numerous threads with this topic but I haven't found one that seemed to address this problem.

Reply With Quote
Old 06-24-2002, 11:11 AM
Registered User
Join Date: May 2002
Posts: 27
I am fightin the same problem on my 560SEL and i have not found the problem yet. Some things to look at further that come to mind-
1)check the coolant sensor and the resistance values
2)check the EHA valve wiring and resistance (it should be about 19 ohms).
3)check the idle control valve wiring and resistance (should be about 5 ohms).
4)Check the OVP relay and fuse.
5)U should also check for fuel pressure leak down.

Good luck and hope u find it.keep us posted.

With mine the idle is very rough until the system goes into Lambda and then it smooths out and speeds up. If i restart immediately it starts right up. If i let the car sit for 45 mintues is starts hard again. Scratchin my head still.
Reply With Quote
Old 06-24-2002, 11:31 AM
Registered User
Join Date: Aug 2001
Location: secret
Posts: 3,044
Same thing with my 300E. I don't think i'm getting power to the cold start injector.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page