Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2002, 05:14 AM
Registered User
 
Join Date: Jun 2002
Location: Monrovia, CA
Posts: 490
Need Help with Electrical Problem

I 've got an '86 300E with 93,000 miles on it. Just today, I noticed that the right turn signal arrow on the dash glows dimly anytime I apply the brakes. If the turn signal is operating at the time I step of the brake pedal, it stops flashing and glows dimly. As soon as I take my foot off the brake, it continues flashing. Does this sound like something is trying to get to ground through my turn signal bulb? What would be the best way of troubleshooting this type of problem?

Thanks,

Gary
Reply With Quote
  #2  
Old 06-25-2002, 11:54 AM
Amuso's Avatar
Addicted to gadgets
 
Join Date: Apr 2002
Location: Norway
Posts: 102
IŽd check for shorts in the rear lights, or bad connections. Take out the assemlby and clean it, and the plug. Check the wires and bulbs to it. Also check the fuses as I once had something similar that was caused by a corroded fuse connection too.
__________________
99 W210 E220 cdi sedan automatic (248.000 km) 210.006
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page