Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-28-2002, 03:31 PM
Posts: n/a
1992 190E 2.6- I've lost my water temp, oil pressure, and fuel gages

The oil pressure, water temp and the fuel gage along with the a/c blower are inop. The a/c compressor is on but no blower. I've checked all fuses and I am lost. PLEASE HELP !!!!
Reply With Quote
Old 06-28-2002, 04:12 PM
Ashman's Avatar
Service Advisor
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
Have you changed the fuse for the ac blower? Someties they can get a hairline crack in them.

Also depending on the car, the gauge cluster has fuses int he back. they look like the bulb holders but are red I believe.

'92 300CE - Sold
2004 C240 - C7 Wheels
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
Old 06-28-2002, 04:47 PM
Posts: n/a
92 190E 2.6 Gages and A/C blower inop

I've found the gage problem but the a/c blower is still out. There was no conection between the 2 problems. I know that the fuse is good. I think that the blower motor may be out but cannot get to it to check it out. HELP me get to the blower motor.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page