Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-01-2002, 09:26 PM
Senior Member
Join Date: Apr 2001
Location: Baton Rouge
Posts: 485
You need to have the codes pulled to see what is going on , there are a number of things that can turn on the MIL. (malfunction indicator lamp) Go to dealer or independant to have these codes pulled. Let us know what codes they are.
euro 287
Mercedes Technician 7 Years (retired to Hyundai)
2000 Dodge Durango
98 Mazda truck
Reply With Quote
Old 07-01-2002, 10:28 PM
Registered User
Join Date: Jul 2002
Location: Florida
Posts: 14
Question "Check Engine Electronics"

My 1996 E-320 has a "check engine electronics" message in the dash panel. I called the dealership and they would only say for me to bring it in and let them look at it. I do not mind doing so if it is necessary but was wondering if this might be something I could check on myself. I am pretty good at working on cars, etc. but I do not have any testing equipment. I rather suspect that the problem is a bad sensor of some kind. Has anybody ever experienced something similar? Any help would be appreciated?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page