Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-02-2002, 07:52 AM
Posts: n/a
Question Immobiliser on S320 1996


I have recently bought a 1996 S320. I am experiencing confusion with the electronic engine immobiliser. According to the handbook, it should only engage when the car is locked with the remote control. However, it seems to come on whenever the engine is turned off, even if the key is still in the ignition. I then have to lock and unlock the car with the remote control before the engine will re-start (even though I am sitting in the drivers seat!). Sometimes I have to do this twice.

My dealer has checked the circuitry and says that the device is working correctly. My request is simply this: Does anyone have any correct documentation for the immobiliser on a 1996 S class, so that I can clearly understand when the device will engage itself.

Thanks in anticipation.
Reply With Quote
Old 07-02-2002, 09:19 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
If you shut off the car, will it not crank at all again without locking/unlocking the car, or will it only crank over and not actually start?
The 96's all had DAS2, which is only supposed to disable the fuel injection system, the starter should still crank. If it won't crank, I would assume a bad ignition switch.
The signal to activate or deactivate DAS2 is either by remote locking OR any of the door or trunk switches, can be done in any combination.
If the system seems to be being set (armed) by switching off the ignition, I would wonder if you are getting a red LED on the interior mirror when shutting off the car, it should be giving the visual confirmation through the red LED when arming, or a green one when disarming. If the red and green LED's are doing something out of the ordinary (flashing back and forth or both at the same time) then there is a problem in the system. Back and forth flashing means that there is an unauthorized start attempt. I would begin by wondering if maybe one of the door switches (or trunk switch) is giving the system a "lock" command due to a bad switch.
Reply With Quote
Old 07-03-2002, 05:10 AM
Posts: n/a

Thanks very much for your comments.

The starter will turn the engine, it just doesn't fire when the immobiliser is set.

I can be a bit more precise in my description of ther problem. If the ignition is turned off, and the engine immediately restarted, there is no problem. There seems to be a delay of about 10 seconds, and then the direction indicators flash once, and the immobiliser is set. If then attempt to restart, the red and green lights in the mirror flash alternately, as you describe. The car then has to be locked and unlocked with the remote control before the engine will fire.

This does seem strange, and is not in accordance with the manual.

However, if I simply unlock the car from outside, get in, and start the engine immediately, there is no problem.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page