Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-05-2002, 04:33 PM
amg280's Avatar
Registered User
Join Date: Apr 2002
Location: NY
Posts: 530
How to remove electronic actuator from 400E

Ive looked inside there and almost seems like you have to take the intake plenum off? Is this true? Doesnt seem like you can get your hands in there. Is this a difficult job? Im thinking this might be the culprit of my ASR woes.

Thanks to all that respond.
93 300D 2.5 Turbo, Black/Palomino 273K
09 E350 Black/Black 41K
Reply With Quote
Old 07-05-2002, 06:27 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Takes about 1.5 hrs & the intake stays on!! after removing the air mass sensor & rubber boot there are 4 bolts holding it on.
After that unhook the return spring & linkage, then disconnect the wiring harness from the quick disconnect is all there is.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page