Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-19-2002, 02:01 AM
Registered User
Join Date: Jan 2001
Location: California
Posts: 2,068
W124 Climate control issues.

All of the buttons on the climate control unit (with the exception of the off button) do the same thing. Air always flows from the side and defrost vents, no matter what. What would most likely be the problem? Bad pushbutton unit? The footwell doors seem to be held closed with vacuum, because I can push them open with my finger, and they spring right back. So I doubt it's a vacuum leak. Thanks in advance.
Reply With Quote
Old 07-19-2002, 08:21 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Does sound like vacuum supply problem, The defrost flaps are spring loaded open however the center vent & footwells are spring closed. So you need vacuum to close the defrost & open the footwell & center vents.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page