Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-20-2002, 11:01 PM
Posts: n/a
Soft Breaks or bad pads ?

Last summer my son replaced by front rotors & pads on (89 300e 200K). Front have squeaked since then. The breaks have been going bad for the last couple months so we pulled the back and replaced rotors and rear pads. Bleed the brakes but still the pedal will go almost to the floor but has pressure on it. The brakes won't seem to stop quickly, it takes effort and a hard push to lock them up. Replaced the front & rear with semi metallic pads.
I'm thinking of replacing my fromt pads with soft Textar OEM pads They only have about 8K on them but squeak bad. Or maybe rebuilding calipers or master cylinder. Not sure what it is.

Suggestions ?

Mike V
Reply With Quote
Old 07-21-2002, 11:40 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
MB specifically says to not use metallic pads.

Resolve your pedal problem. You have either had a master cylinder failure or haven't bleed the system properly from the symptoms you state.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page