Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-01-1999, 11:17 AM
gp56
Guest
 
Posts: n/a
Car runs at about 85 degrees on the parkway, goes over 110 degrees in stop and go traffic. Thermostat and fan clutch have been changed. Any ideas?
  #2  
Old 06-01-1999, 03:43 PM
krystal_blade
Guest
 
Posts: n/a
On mine (190D) I had to replace the thermal sensor for the fan.

If your a Do it Yourselfer, try this

Start the engine, open the hood, and look for an electrical connector on your high pressure coolant intake.

Look for your temperature sensor, which is a thermistor.

Once you find it, check the connection by shorting it to ground. If the fan comes on, change the sensor.

If it doesn't, check the wiring in between the fan assembly, and the sensor.

krystal_blade@hotmail.com
  #3  
Old 06-01-1999, 05:32 PM
gp56
Guest
 
Posts: n/a
Electric Fan comes on at about 105. It just seems like a tremendous increase in engine temp as soon as city driving is encountered.
  #4  
Old 06-01-1999, 07:32 PM
MB STARS
Guest
 
Posts: n/a
Here is the way to check your radiator
run the engine first wait it gets hot 110c
then turn the engine off put your hand in center of the radiator (right in front of the fan clutch) if is cold or warm or rest part of rediator is hotter then the center
you have a bad radiator replace it.
warning !! turn engien off when you test the
radiator.
  #5  
Old 06-01-1999, 10:30 PM
Benzmac
Guest
 
Posts: n/a
I have seen many radiators faulty in the way that you are describing. This is due to reduced capacity.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
606 running hot? liamd Diesel Discussion 9 12-18-2004 12:37 AM
560 SEL - Hard to Start jgl1 Tech Help 6 11-21-2004 01:57 AM
86 560 SEL Running Hot?? fitzalon Tech Help 0 09-25-2002 11:25 PM
'88 560 SEL - Nagging issues - please help? McLaren Tech Help 6 08-17-2002 03:31 AM
1986 560 SEL for sale mgnut Mercedes Cars For Sale 0 07-22-2002 07:32 PM



All times are GMT -4. The time now is 08:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page