Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-05-1999, 07:30 PM
Marco
Guest
 
Posts: n/a
Hello Folks,

Long time no talk.
I live in Los Angeles, Temp approx 75. Today the E320 suddenly gave a "Engine Fan" mulfunction display, the words were spell out in the trip odomotor display and the total miles display. I had my Fan running on "auto 72" at the time. I have no idea what could have cause it, I call the dealership but they seem unconcern and wanted me to bring it in 2 days later.

Later on, it went on again while I was driving with the fan on (no ac). Any idea what's happening with it and should I be majorly concern?


Thanks in Advance,



------------------
Happy Cruzing...

///Marco
-Opera Design Silver E320 99"
-245/275 P-Zero 19"
-Full Opera Design W210 E-clas body kit ( The First one in U.S.)
-Opera Design Sport Exhaust
-Show car for Wheel Power Inc. (wheelpower.com)


  #2  
Old 06-05-1999, 11:35 PM
Corky
Guest
 
Posts: n/a
Marco
Engine Cooling fan warning diplay in the muitifunction dispay is a indication of a
fault/failure in the electric engine cooling fan circuit, it has nothing to do with the climate control fan. Did the engine temp. indicate that the engine was overheating?
If the car is not going to the dealer for a couple of days I would watch the engine temp. closely.
  #3  
Old 06-06-1999, 05:25 AM
Marco
Guest
 
Posts: n/a
Thanks for the help.
I have been watching the car temp. display it seems like it's in the range of 80~85. is that normal? The dealer's service advisor comfirm on the phone that " IT's OKAY, don't worry"...I figure today is sunday and if something happen to me on the road..I wouldn't find him anyways..ha.
Thanks for the tip,

I'll keep the driving only to the local market.



------------------
Happy Cruzing...

///Marco
-Opera Design Silver E320 99"
-245/275 P-Zero 19"
-Full Opera Design W210 E-clas body kit ( The First one in U.S.)
-Opera Design Sport Exhaust
-Show car for Wheel Power Inc. (wheelpower.com)


  #4  
Old 06-06-1999, 01:24 PM
Benzmac
Guest
 
Posts: n/a
80 to 85 is fine. If it gets hotter than that be careful not to damage your engine.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 06-07-1999, 05:33 PM
Marco
Guest
 
Posts: n/a
Thanks folks.

I just got the word from the service advisor that the "aux. fan" is busted and needs replacement, that's the problem which is causing the "engine fan" display to show up.

Make sense? I hope, because they're parking it over night for the parts to come tomorrow.


Thanks,


///Mark
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reset FSS W210 E320 Doesn't Work DaveJ Tech Help 7 05-25-2015 04:38 PM
1994 E320 fault code 35 and 84 J. M. van Swaay Tech Help 11 01-08-2005 02:40 PM
2000 W210 E320 "Engine Fan - Visit Workshop" ckNSX Tech Help 1 03-01-2004 09:26 AM
Seeking fault codes for 1996 E320 (W210 / M104) aTOMic Tech Help 1 08-13-2002 01:16 PM
W210 E430 v's E320 BScottB Featured Cars 13 05-17-2002 04:02 PM



All times are GMT -4. The time now is 01:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page