Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-05-2002, 11:16 AM
Registered User
Join Date: Feb 2001
Location: NW Arkansas
Posts: 179
w126 blinker slowly stopped working

1981 300SD

Sunday morning, blinkers worked fine. Then, later in the afternoon, I go to make a turn, and the blinker would blink a couple of times, then stop. Turn the blinker the other way, same thing. It did this several times, then stopped altogether.

I checked the bulbs in the back, I had a couple that needed to be replaced, so I replaced them. Same problem.

I search the forums and saw a message about cleaning the hazard switch???

Also, how could I tell if the relay is bad? The relays are under the hood where the fuses are and shaped like silver "cubes", right?

What type of troubleshooting could I do?

1994 C280 204k miles
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page