Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-10-1999, 06:24 AM
Mike B
Posts: n/a
The central locking on my '87 300SL spuriously turns itself on and off both when driving and when parked. I have played about with the system by connecting/disconnecting the wires to the control box in the boot. Through this testing work I think the problem lies in the wiring to the drivers side door mechanism (the door switch itself has been replaced - no change).
It does seem to be worse if the weather's wet whcih may suggest an earth fault somewhere.
I do not know the routing of the wiring from the control box to the door or whether there are any well known problems with this system. The car did have an alarm fiited by a previous owner that connects into the central locking system somewhere but this never worked well so it has been unplugged but not removed completely.

Any guideance would be welcome.

Old 06-10-1999, 08:28 PM
Posts: n/a
You sound as if you are not in the USA
The 300SL was not a US spec car. I am going to give you information that would be relevent to US spec cars and may or maynot work on your car.
The central locking pump recieves signals from the vac lock actuators in the doors. they have a three pin electrical connector on them. In the rocker panel area just ahead of the door opening is a flat three pin connector that has been known to become corroded and cause a short that will drive the CL system nuts. The best thing that you can do is get a wiring diagham and isolate each part of this circuit untill the fault is laocated and repair. Good Luck and have fun.
Old 06-13-1999, 04:26 AM
Mike B
Posts: n/a
Thanks for the advice. You're right - I live in the UK and the 300SL is therefore European spec. The US CL system you describe sounds identical to mine - I guess it would appear on your model 560SL which was out about the same time I think (late '80's).
Could you be more specific about the location of and access to the rocker panel where the 3 pin connector is? Is it in the body of the car close to the door hinges? How do I get at it?

Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190E wiring query - central locking greenpc Tech Help 4 12-11-2014 02:05 AM
1992 500 SEL central locking problem BernardSmith Tech Help 5 11-29-2004 03:57 PM
Central locking problem on '87 W126-help? JustinMorrison Tech Help 16 05-26-2004 06:34 AM
560SL central locking bhatt SL Forum 2 01-05-2004 08:50 PM
Central Vacuum Locking System - W140 sail42 Tech Help 1 01-16-2002 10:12 AM

All times are GMT -4. The time now is 04:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page