Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-11-2002, 08:31 PM
Biosmell's Avatar
Registered User
Join Date: Aug 2002
Location: Nor Cal
Posts: 26
Angry 84 300TD standing lights won't shut off!

All right. so I had the infamous steering lock failure and had to pull the dash, drill out the pin and replace the ignition assembly. Everything works great, however my standing/parking lights (the bottom reds in back, the sides in front)won't turn off until I pull the Battery cable?! Now while I did have to remove the lighting switch from the dash, I did not mess with it or pull it apart. I suspect that this is an unrelated problem (to the ignition thing), but does anyone have enough electrical knowledge to help troubleshoot this with me?
Many Thanks in advance,
El Jefe de Biosmell
84 300TBD-T (that is B as in BIO-Diesel!)

P.S. I thouroughly checked the color coding with the factory specs on the instrument cluster multi plug and it was perfect, so no cross wiring there. Any one out there know how to bench test the lighting switch? I seriously cannot figure what else it could be.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page