Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-14-2002, 02:10 AM
Posts: n/a
Unhappy A Few Engine Problems

I have a 1985 MB 190E 2.3

It has 215,000 miles on it. It has an erratic idle when it warms up...(1,000-1500+ sometimes) and it fluxuates. Can it be my idle speed control valve? There is also this screw under the air cleaner in the block which i can adjust my idle with but it never stays normal ( I dont think its supposed to be there ) When I put it into gear at high idle, the tach will drop to about 500 or less and struggles and gets back up to about 1000...and in reverse at high idle, it actually peels out! (embarrassing) This is my main problem with the car.
I also have a problem with my electromagnetic fan...
I think the clutch or thermostat may be bad...the fan is constanly never shuts down to its standby slow rotation on this would be greatly appriciated! Thanks!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:45 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page