Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


  Join us November 1st for Casino Night at the Pelican Parts Open House!
Benefiting LuMind - Research and Treatment for individuals with Down Syndrome
Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-2002, 07:02 PM
Registered User
 
Join Date: Feb 2002
Posts: 23
Unhappy 95 S320- Asr & Abs & Srs Light On...

I have a 1995 S320 long wheel base I bought in Feb 2002.
Today I go out the start the car and the ASR, ABS & SRS lights
come on in the order:

1) Start Car- SRS light comes on. Stays on for about
two minutes then turns off.

2) The moment I touch the brake pedal both the
ASR and ABS lights come on. Only when I
touch the brake pedal.


If I start the car and turn the steering wheel everything
feels normal. The moment I touch the brake pedal both
ASR & ABS lights come on. The steering wheel becomes
and feels almost like manual steering.

I am not certain what to do. I fist got a bulb out light
indicator that kept coming on. Replaced brake lights
and rear third brake light. Could this have triggered
anything.

Any help would be appreciated as I do not know much
about this type of problem.

I am afraid the "Stealer" is going to say everything
has to be replaced and I will have to sell my house
and take public transportation to work. Help me please....

Tully
Reply With Quote
  #2  
Old 08-14-2002, 08:34 PM
Registered User
 
Join Date: Jun 2002
Location: Cumming Ga.
Posts: 237
The SRS light coming on is indicating a problem in the system.The most common fault would be one of both of the front seat belt buckles. You probably have a faulty brake light switch causing the ASR and ABS lights to come on.
__________________
Mercedes Benz Master Tech
Reply With Quote
  #3  
Old 08-14-2002, 10:03 PM
Registered User
 
Join Date: Mar 2002
Location: Great White North!!!!
Posts: 400
RPM 55

my asr light comes on as well for a couple of minutes at start up.i had read it could be the buckles or a contact in behind the steering wheel that becomes 'dirty'.if it's the buckle,what is setting it off?can i fix it?
__________________
'95 s500 (bought for wife but can't bear to share!!!) 125kms
'92 legend 180kms
'88 tbirdturbo(fantastic car-only regular maint.)120kms
'87 mustang gt(gone)
'86 tbirdturbo(gone)
'85 mustang gt(gone-but not forgotten)
Reply With Quote
  #4  
Old 08-15-2002, 08:16 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Have BOTH systems tested with scan tool & then you can make diagnosis. ANYTHING else is just guessing!

More likely than not the SRS problem IS a bad buckle but which one??
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 08-15-2002, 08:16 AM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page