Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-22-2002, 02:53 PM
Registered User
 
Join Date: Feb 2002
Location: Winona Mn.
Posts: 9
Question 85 190E 2.3 no power

Car starts and runs fine, idles perfect but will not rev over 2000 rpm. Has new plugs,wires,cap,rotor,coil,fuel filter, and 02 sensor. She has 210,000 miles on her so is probable a little tired. I would like to keep her going a little longer if possible. Any help on this would be appreciated! Thanks, Sammy
Reply With Quote
  #2  
Old 08-22-2002, 02:59 PM
1992300e
Guest
 
Posts: n/a
Low RPM

Not sure if I can help but just recently, yesterday, I crapped out my OVP (Over voltage protection, something like that). I blew a fuse and did some searches. Seems like your syptom could be caused by bad OVP, not even sure if your car has one.

Try a search,,

Good luck,
Joel
Reply With Quote
  #3  
Old 08-22-2002, 03:04 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,790
A clogged cat. converter or restricted exhaust can give these symptoms. When the car is cold, grab the converter and give it a shake. If you hear any rattling, you've found your problem....the ceramic monolith inside is breaking up and restricting exhaust.

Beyond that it could be something like a weak fuel pump, clogged sock filter in the tank, or something else with the fuel delivery system.

Or perhaps the ignition timing or valve timing is off.
__________________
95 E320 Cabriolet, 140K
Reply With Quote
  #4  
Old 08-22-2002, 03:14 PM
Registered User
 
Join Date: Feb 2002
Location: Winona Mn.
Posts: 9
The cat has been off for a couple of years, otherwise exhaust is fine. I have not checked timing yet. Does anybody know where cam alignment are suppoesed to be in relation with TDC of crank?
Reply With Quote
  #5  
Old 08-22-2002, 03:29 PM
Registered User
 
Join Date: Apr 2000
Location: LEMONT-CHICAGO
Posts: 412
Sounds like a restricted exhaust. Crack open the exhaust at the exhaust manifold and see if the engine will rev.
__________________
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote
  #6  
Old 08-22-2002, 04:56 PM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,790
Try checking the fuel pressure. The pressure regulator may have gone south.
__________________
95 E320 Cabriolet, 140K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page