Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-04-2002, 05:27 PM
Posts: n/a
79 450 slc starting problems

car requires excessive cranking to start.Once started it runs fine. The fuel pump does not seem to get power with the key in the run position. While starting the car, power is present at the fuel pump. With the car running the pump has power. I checked the fuses (drivers side kick panel)all are fine. Are there other relays or such anywhere else- trunk? How about a malfunctioning pressure shutoff switch on the manifold some where. Also car draws so much power cranking it runs the battery down, is it possible the starting motor is drawing so much power it sucks it from the pump.:confused:
Reply With Quote
Old 09-05-2002, 12:03 AM
Senior Member
Join Date: Mar 2001
Location: Accokeek, MD
Posts: 683
I'd start by looking at basics like the fuel filter to see if its cloged. When was it last changed?

1993 190E 2.3
2000 Toyota 4x4 Tundra
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page