Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-07-2002, 09:10 PM
downsmith's Avatar
Registered User
Join Date: Jul 2001
Location: Oklahoma Sooners Alumnus
Posts: 116
Angry HELP!!! Cannot start the '85 500SEL

I would really appreciate someone's help....I did something really stupid!

I was trying to diganose a rough running problem when I pulled the fuel pump relay out of the socket while the engine was running. It ran for about two seconds and stopped. I expected that. What I did not expect was that when I plugged it back in, the car would not start.

I opened the relay and sure enough, a solder connection was broken. I repaired the break and expected that to be the guessed it; it was not.

I loosened the main fuel line to see if the pump was working and it was (The garage still smells of gasoline). So I hooked up my timing light to check for the presence of a spark and got no strobe.

Now I am at my wits end. Is their any suggestions?

R. Downs
1985 500SEL (260,000 miles) SOLD!
1974 280 SOLD!
1994 Volvo 850 Turbo Wagon (Yuppie Ice Sled)

"I know I have a Benz and they know it too." If you start bragging about it or shoving in people's face, you then become a Wally; especially to the girls.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page